Results 1 to 11 of 11

Thread: Trouble with cutting Vector Letters in Trotec Ruby

  1. #1

    Question Trouble with cutting Vector Letters in Trotec Ruby

    Hi everyone! One of our shop lasers (Trotec Speedy 300) is having some very peculiar difficulties. Long story short is that it will absolutely not vector cut the letter 'M' which is stopping several raised-letter ADA jobs in their tracks. So far 'M' is the only letter where this is an issue. All other letters and numbers will cut perfectly fine. The laser will do it's thing, start the 'M' in the bottom left, and by the time it gets to the top right it will stop in place for a few seconds before sending out the 'Job Complete' beep. If there are any letters that need to be engraved after the 'M', it's as if the machine completely forgets about them, and it treats the 'M' as the end of the line. Other than not recognizing when a rotary attachment is hooked up (which we are currently trying to work with Trotec to figure out), everything else about the laser works fine as far as we've encountered.

    We've tried engraving as text, and converting everything to curves in CorelDraw before importing into Ruby, but no dice. Lowering the speed and removing other letters will get the laser to cut further along the outline of the 'M', but still not all the way. Perhaps related, this same machine is one that was delivered with a nasty crack on one of the exterior fans (sales/installation rep got that replaced and said the rest looked fine). My thoughts are that something is damaged internally, but until we get a tech out we can't say for sure.

    I'm going to reach out to Trotec Support (again), but figured I'd check if anyone else has had experience with similar issues, or might be able to offer some insight. If for no other reason than to help preserve my dwindling sanity at this point.

    Thanks!

  2. #2
    Have you tried different fonts? How about exporting then importing the M as a DXF or EPS?
    ========================================
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE- make that FOUR now - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle


  3. #3
    Thanks for the suggestions! Tried those this morning (with the exception of importing EPS, since Ruby seemed to have trouble with that), and everything worked, until we did second and third runs to confirm and the issue began again, same as before. The weird thing was that the original problem font, Helvetica, was also working fine the first couple of runs.

    Basically been running test jobs all morning, and now ruby is throwing out hardware errors about the x and y axis. 'Motor over current phase V' is the most recent, and that one started flashing the moment the laser got caught on the 'M', which is new, so we're backing off for now until we get contact back from Trotec...

  4. #4
    Have you tried switching back to Job Control? Ruby is not bug free.
    Mike Null

    St. Louis Laser, Inc.

    Trotec Speedy 300, 80 watt
    Gravograph IS400
    Woodworking shop CLTT and Laser Sublimation
    Dye Sublimation
    CorelDraw X5, X7

  5. #5
    Hah, you're telling me... No, we only got the lasers up and running this past January, so Ruby is the only software that has ever been used with them. The guy who did our installation seemed pretty dismissive when I asked about getting a copy of JobControl as a backup software (what with it being more tested and having more tutorial and training resources...), but I'll ask again with the support tech.

  6. #6
    Ask the tech, I could provide you with a copy of Job Control 11, but you would need a license code to activate it. So all roads lead to a tech, plus I would want a JC11 license code for each new laser anyways. As Mike mentioned Ruby is not bug free, I find it pretty good but there have been several instances where I have gone back to JC. Especially with how confusing firmware updates are on Ruby. It is probably worth sending feedback via the Ruby feedback link as the people in Germany are looking at each piece of feedback and you might get the developers at HQ to implement a fix quicker.

  7. #7
    I’m being told by my rep that most of the current problems are due to user error, whereas I was in the beta and could never get it to work so I’ve been running JCX for years without issue. Is Ruby still having problems as of today? Reminds me of the grounded Boeing.
    355 - 10400 : )

  8. #8
    I shot you a DM with a couple support peoples names that I think are quite good and shouldn’t pass off the blame on you. I know enough to be dangerous but not as much as them. Feel free to reach out if you think it would help.

  9. #9
    Quote Originally Posted by Neville Stewart View Post
    Is Ruby still having problems as of today? Reminds me of the grounded Boeing.
    Most of our issues so far seem to come from the fact that we're on a controlled University Network that intersects with a private network which causes a million different little communication hiccups on all of our machines and cutters... So far this issue (which I may have figured out!!) and an issue with our rotary (which we've all but narrowed down to being a bizarre hardware issue) are the only problems that we've had. My biggest gripe would have to be a lack of some QOL features in relation to what our sales guy had promised, but with our weird shop setup, and multiple users, the convenience factor of remote access more than makes up for it imo.

    POSSIBLE SOLUTION TO THE OP INCIDENT
    After digging around more, running some tests, and finding an older post on these forums from 2011 (seriously, this place has been a great resource), I think we figured out what was going on. I hadn't thought to check until I stumbled on that old post, but when Corel converts the capital M in Helvetica to a curve, there are a bunch of superfluous nodes along straight lines, and the corners have 2-3 nodes all stacked on the same spot. Once the extra nodes were deleted, it seemed to cut just fine.
    Helvetica_M_Nodes.PNG
    Unlike Chase, I don't quite know enough to be dangerous, but if my understanding is right that the engraving software treats nodes as 'decision' points, then my guess is that all those decision points right on top of each other was causing the machine (or the hosting computer?) to get overwhelmed and lock up.

  10. #10
    There is a recent update to Ruby available for download.

    It doesn't make sense that you do not have JC.
    Mike Null

    St. Louis Laser, Inc.

    Trotec Speedy 300, 80 watt
    Gravograph IS400
    Woodworking shop CLTT and Laser Sublimation
    Dye Sublimation
    CorelDraw X5, X7

  11. #11
    Join Date
    Jan 2017
    Location
    Chicago, IL
    Posts
    39
    Quote Originally Posted by Mike Null View Post
    There is a recent update to Ruby available for download.

    It doesn't make sense that you do not have JC.
    I agree with Mike. You should still have the right and the ability to claim your JC installation. If for no other reason than to troubleshoot anything "weird" going on in Ruby.
    Yes, it is being phased out but that day has not yet come and many of the die-hard daily job shops out there will ride it out until windows forces it into extinction. Not because Ruby is inferior, but a new program means overwriting your stubborn habits, shortcuts, muscle memory, file structure, employee training, workflows, material groups, custom plates, calibrations, etc... kind of alot to change all at once. But you CAN go back and forth between the two and will probably find that occasionally you'll need to. I'd settle in to Ruby if arriving at this stage in the game. you wont have as much un-learning to do as alot of us. But definitely have both installed as a failsafe and troubleshooting tool. Trotec machines rarely ever have downtime though so you're already a step ahead.
    Trotec Speedy 360 80watt, Woodworking, screenprinting, paper marbling and an all around assortment of art supplies.
    I make art, my laser makes money. which i spend on art tools like lasers.
    MAKE it 'til you make it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •