Results 1 to 3 of 3

Thread: Laser lost power

  1. #1
    Join Date
    Sep 2009
    Location
    Medina Ohio
    Posts
    4,264

    Laser lost power

    I just went out to cut some stuff and noticed that the AMP meter is only reading 10 Milliamps. I haven't used it for about 2 weeks and it was cutting fine then. How can I tell if it is the tube or the power supply.

  2. #2
    I've never had to test for low output, but, I'd grab a good multitester and check the output voltage(s) at the power supply. If okay while idle, then test again while the laser under load...

    Probably not your issue, but for awhile I was noticing with my Triumph, when cutting the beam would seem to 'flicker'. And this flicker was showing up on the meter; while normally the needle doesn't move whatsoever, when flickering it would bounce around slightly. The plasma(?) in the tube was also circling around the nozzle, which I'd never seen it do (but then, I don't watch it much ) -- anyway, one day for fun I just wiggled the wires on the mA meter, and after that it hasn't flickered again... If there's one common denominator I've suffered with in running computerized machines for 40 years, it's "iffy" connections. For the last 10 years or so if a machine acts even the least little bit funny, I'll grab a can of spray electronics cleaner and start pulling plugs and IC chips and douse them all. My GCC I bought used from Gary, 8 years ago-? - twice I've had it just 'give out', and before it did the tattletale has been the LCD display going "light" to where I can barely read it. Cleaning every connector I can pull apart on the motherboard and all power supplies brought it back to life... As of last week I noticed the display is getting hard to read again, not dark like it should be, so it's heading downhill again and will get its 3rd dousing sometime this week

    Anyway- check those volts, check connections, check the meter for 'bouncing'...
    ========================================
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE- make that FOUR now - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle


  3. #3
    Join Date
    Sep 2009
    Location
    Medina Ohio
    Posts
    4,264
    I did the power supply test for my 130 watt tube using the resistor I got for my 50 watt tube I am getting 40 milliamps on the meter is this a sign of a bad power supply

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •