Results 1 to 4 of 4

Thread: Chinese Laser with Ruida RDC6442S-B (EC) Controller - Stopped Working

  1. #1

    Chinese Laser with Ruida RDC6442S-B (EC) Controller - Stopped Working

    Hello,


    Iíve recently been tasked with finding information to fix a Chinese Laser Engraving Machine. It has a Ruida RDC6442S-B (EC) Controller.

    The exact Laser can be found at the following link (The Laser Iím working on wasnít bought from this site though).

    https://www.ec21.com/product-details/Laser-Max-Factory-Price-60WĖ11325640.html


    Essentially, the company that I do work for purchased this machine from a third party a few months ago. The only instructions we got from the Supplier was a USB with an arbitrary driver and a half chinese video showing how to install the software (which was quite unhelpful).


    When they first got the machine, it worked perfectly. We use Lightburn. The machine has two unlabelled USB ports on the side. We first sent jobs to the Engraver by plugging in a USB drive into one of the ports. The Engraver would detect the drive and the job would commence.

    However, the USB port on the machine broke off after a month. The side of the Engraver was opened and the USB drive was connected directly to the Ruida Controller via an extension cable and it worked.

    However, we directly connected the Ruida Controller to the PC via the PC-USB port. With this, we could send jobs directly to the Engraver from Lightburn/RDWorks. This worked for 2 months.

    Then, the Laser tube stopped working for some reason. A new laser was purchased and installed. The machine worked for 1 week.

    Fast Forward to today, nothing is working. Connecting the Ruida Controller directly to the PC does nothing. Connecting drives to the U-Drive Port on the controller does nothing. Iíve connected a ethernet cable into the Ruida Ethernet Port, configured a static IP on the device for the network. The Ruida Controller comes up on the network, however Lightburn nor RDworks detect the laser at the IP. I want to reiterate the if you ping the IP or scan the network, the Ruidaís IP is detected.


    I am at my wits end with this machine and need some assistance.


    Iíve included the following links with pictures which should assist.

    https://ibb.co/FqtCH1Z
    https://ibb.co/T24LpPf
    https://ibb.co/cC11PLp
    https://ibb.co/vctSD1x
    https://ibb.co/r4LL00D
    https://ibb.co/F7HZ9Vj
    https://ibb.co/0qRYdng
    https://ibb.co/CP2wq7h
    https://ibb.co/3Rz0TtX

  2. #2
    I've gotten extremely good service out of my machines over the years (knock on my head!) -however- I've had pretty bad luck over the years with anything to do with USB ports, cables, connections, etc... In fact, at this moment, to get my 80w Chinese Triumph to accept a job from the computer, I have to disconnect and reconnect the USB cable, every single time-! I bought a switched USB hub to make that easier but it's still a pain. Also, I too lost the cabinet-to-controller USB connection a long time ago, and I'm now connected directly to the controller. And, I'm also on my second controller, because, the old one stopped accepting ANY USB input. It would run old saved jobs just fine, but nothing via USB connection, or flash drive....
    ========================================
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE- make that FOUR now - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle


  3. #3
    Join Date
    Dec 2010
    Location
    NW Arkansas
    Posts
    1,821
    Blog Entries
    1
    I've an old HP laserjet that connects through usb whenever it wants to. Or not. USB on some devices is really a crap shoot. I have to unplug and replug that printer 85% of the time and restart 5% of the time. Roughly 1 time out of 10 it works when I turn it on. But it's free and paid for and prints.
    Now my Ruida controlled laser is run through ethernet. But you cannot connect computer direct to the laser. It has to go through at least a switch to make the computer and the laser assume they are on a network.
    I have an old router that I use in my basement to drive my internet from a powerline adapter. The laser and the computer are both connected via ethernet cables to the router and it works.
    You said network, so hopefully you have it on a network and the above is extraneous.

    You do need to put the IP address in the controller and I used this for gateway - 255.255.255.1 And it must be the same in the software.

    If both are the same, restart both computer and the laser. If it still doesn't work, you most probably have bad controller, but I would swap ethernet cables to insure that you have a good cable. Stupid stuff happens to cables.
    Woodworking, Old Tools and Shooting
    Ray Fine RF-1390 Laser Ray Fine 20watt Fiber Laser
    SFX 50 Watt Fiber Laser
    PM2000, Delta BS, Delta sander, Powermatic 50 jointer,
    Powermatic 100-12 planer, Rockwell 15-126 radial drill press
    Rockwell 46-450 lathe, and 2 Walker Turner RA1100 radial saws
    Jet JWS18, bandsaw Carbide Create CNC, RIA 22TCM 1911s and others

  4. #4
    Join Date
    Dec 2016
    Location
    Helena, MT
    Posts
    122
    Quote Originally Posted by John Lifer View Post
    But you cannot connect computer direct to the laser. It has to go through at least a switch to make the computer and the laser assume they are on a network.
    Just an FYI, this statement is incorrect. You can in fact put a cable directly from your computer to your laser and it will work fine. Pretty much any computer with a Gigabit Ethernet card in it will have what is called Auto-MDIX in it, meaning it will automatically flip the pins (1,2,3 & 6) virtually in order to do this. If you have a card that does not have Auto-MDIX in it, you can just purchase a "Crossover" Ethernet cable that has the wires flipped (1,2,3 & 6) in the connectors for this to work. https://en.wikipedia.org/wiki/Medium...dent_interface https://en.wikipedia.org/wiki/Ethernet_crossover_cable
    Last edited by Steve Utick; 09-24-2021 at 9:40 AM.
    Epilog Fusion M2 32 - 60 Watt
    CamFive CFL-CMA 4032K - 100 Watt
    Boss Laser LS-3655 - 100 Watt
    APLazer SN1812 - 40 Watt
    Radian RL-GT3-F30J JPT 30 Watt 3D MOPA Fiber

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •