Page 4 of 4 FirstFirst 1234
Results 46 to 57 of 57

Thread: Dream machine acquired - SCM L’invicibile S50 planer

  1. #46
    Quote Originally Posted by Brian Holcombe View Post
    For a machine of that quality IMO I would think that something from Mitutoyo or similar level of quality would be called for. It’s a top quality machine, spending a few more bucks upfront to get similar quality in accessories seems well suited.

    I have some mitutoyo digital stuff that is over 20yrs old still working perfectly. By comparison the one time I did buy an inexpensive gauge from a well known company it died in a few years or daily use. That reinforced my perspective that the inexpensive tools just mean that you buy it once, it dies and then you buy a better one later.
    Thanks Brian. I agree. I’m considering the ProScale 10” DRO. I looked briefly earlier, but only saw a 6” travel Mitutoyo DRO. Do you happen to know if they make one that travels at least 10”?
    Still waters run deep.

  2. #47
    Join Date
    Aug 2013
    Princeton, NJ
    Blog Entries
    Proscale looks like a nice setup. Here is the mitutoyo catalog, I’m not sure which style you are interested in but they will definitely be able to cover that range.
    Bumbling forward into the unknown.

  3. #48
    I would go with an Accurate Technology unit, I had several used in a commercial shop with heavy usage on a slider then used on a cabinet saw without issues ever once for 20+ years except for the copper battery terminal got screwed up due to battery leakage, the company is great, they sent me new ones and didn’t even charge, they even offered to upgrade at a reduced cost since I had one of the originals that they made.

    Quote Originally Posted by Phillip Mitchell View Post
    I’m planning to add a Wixey digital read out. It’s a bit too old school to have one from the factory.

    Edit: on second thought...the Wixey looks like it only goes to 6” height. This planer has a height capacity of 9 1/2”. Does anyone know of another option for aftermarket digital readout that will handle this range?

  4. #49
    Just a small update. A kind soul over on OWWM who has owned this planer for 40+ years was nice enough to scan and upload the manual for this machine. Several different google searches yielded no such manual for me prior to this, so I'm happy to have it downloaded. I'll upload it here just in case someone else comes along after me and is looking for it as I was.

    Edit: the size of the PDF is apparently too large to upload to this forum, so if someone wants to download it go here -> or contact me and I'm happy to email the PDF.
    Still waters run deep.

  5. #50
    I pulled out each knife and gib / knife locking bar and all its associated bolts and screws sequentially last night and deep cleaned each piece, let them dry and reset all the knifes. Relieved that all the gib bolts where in good condition, none of them stuck or rounded heads and everything cleaned up pretty well with some elbow grease. There was a good bit of crud built up, and I’m glad I went systematically through and checked and cleaned everything.

    I didn’t snap a photo of it happening, but I used the supplied factory knife setting jig and it made quick work of setting the knives. The cleaning was a bit tedious, so it was nice to have the jig. I could probably pull and reset knives in the future in about 5 minutes (or less) per knife if there was no cleaning and scrubbing involved.

    My next step is to grind the knives.

    Looking at the position of a few of the chip breakers, they are not exactly in plane with the others. I’m wondering if I should attempt to line them all up 100% or leave them alone for now and see how wood feeds after grinding. They are spring loaded and have a set screw to adjust their “height”, but the 1 section that seems the most out of plane appears to be the only broken set screw.

    The last 3 photos are pre-cleaning and you can see the tops of the sectional chipbreaker in the 2nd photo.




    Still waters run deep.

  6. #51
    Join Date
    Mar 2008
    Yeah mine are a little wonky as well. Doesn't really bother me as everything works well. I'd try running material and see how she does before tinkering around to much.


  7. #52
    I ground the knives last night. The adjustment of the height of the grinder is an interesting arrangement. Not as precise or positive as I’d like it to be, but it is what it is.

    The weird thing is that after cleaning everything up from grinding, I went to start the machine and it was as if my phase converter couldn’t handle the load to start it. I started the machine previously in my shop multiple times (with exact same RPC and wiring) about a week ago, so I’m a bit puzzled. The lights dim a bit when attempted to start the planer. The main service is 200 amp single phase. I’m showing my ignorance with loads and amps, but is it possible that for some reason there wasn’t enough amperage available to feed the RPC a full 60 amps to start the planer? It seems like a breaker somewhere would trip if I was calling for more than 200 amps at once and seems highly unlikely as this was late last night and the other household loads (basement shop that shares panel with house) didn’t seem that high, but who knows...

    After pressing the start button it would begin to start / cutterhead and feed start to rotate for maybe half a second or a little more in some cases but then cut out before reaching full speed. The phase converter kept on running (didn’t trip main single phase 60 amp input breaker.). The RPC had been running a while prior to this as I was operating the grinder on the machine (small 3 phase Motor) but in theory is should be able to run for hours on end and still have 10 hp worth on demand.

    One thing I noticed once running it initially in my shop is that the start button is actually a plastic threaded “plunger” type mechanism that engages the actual switch inside the starter. The plastic plunger seems a bit bent and looks like it could be slipping off the side of the actual start switch (which is a square plastic plunging mechanism) before it has the chance to get 100% positive engagement. Seems like it would either be on or off and no in between, but this could be part of the problem. I hope it’s as simple as this and not an issue with the RPC.

    I will disassemble the plastic start plunger mechanism and see if I can reinstall it / bend it back where it needs to be to positively engage the start button inside the starter.

    Any thoughts?
    Last edited by Phillip Mitchell; 08-04-2020 at 1:00 PM.
    Still waters run deep.

  8. #53
    Since you just used the grinding jig, is there any chance the head lock for grinding is still partially engaged?

    That would certainly make it harder to start.

  9. #54
    I had one switch apart a start button about 20 plus times till I got it to work and only then by bending some contacts. Since its worked fine.

    The roto they are all diff. My brand 10 HP will start a 10 HP load. It will bump to 165 amps on turn on split second then idle to whatever. Model I have has extra gizmos in it to make it stronger than the base model, Voltage regulation and bit more. Then they had a hard start model. Mine started a heavy load 10 HP motor with no issues ever. Id check your manufacturer first ive seen enough posts that say you need 20 hp model to start 10 HP and that is wrong based on the brand I have, 10 HP starts 10 HP. 3HP roto starts 3 HP, id started 4 HP many times on the MOrtise machine and the roto could not care less., lower load to start than some machines. The 3hp Combo machine has a heavy head and shaft and 3 HP roto simple same brand old no extra stuff worked fine as well.

    Also be sure you dont run the manufactured phase from the roto to the contact that goes to the coil. I took a coil out doing that then replaced it and fine since
    Last edited by Warren Lake; 08-04-2020 at 1:28 PM.

  10. #55

    Funny you should mention that...the first time I tried to start it after grinding, I’d forgotten to unlock the cutterhead and realized it immediately and pressed the stop button in as fast as possible. Unlocked it after that, but I sure felt like a dummy for a few minutes. I hope I didn’t damage anything by accidentally doing that for a split second, although it seems like damage to the actual cutterhead from that seems unlikely as it’s not like it’s moving then suddenly stopped by a lock, but instead locked from the beginning and building up friction somewhere else momentarily.


    Thanks for the thoughts. I’ll take a look at the switch this evening. I hope that’s what’s going on.

    My RPC is a Kay Phasemaster MA-R 2 VS, which is rated to start up to a 10 hp motor and will run 30 hp. It started the machine multiple times about a week ago so I have a hard time believing that it now won’t and it’s in the RPC.

    Thank you both for the replies.
    Still waters run deep.

  11. #56
    likely every old guy has forgotten once or twice to take the spindle lock pin out once or twice in their lifetime. Never heard of perm damage from that. I would think if you loaded it enough then it would take out the high amp setting in the switch.

    Also I dont know that machine but some machines have transformers. A thing one day I learned about putting a continuity tester on for some reason and two phases lit it up? Puzzled I was told the machine likely has a transformer, then told the coil will be on that circuit. Number of guys here know this stuff inside and out.

  12. #57
    I tore apart the switch and fussed with it and I think I’ve solved my problem, hopefully.

    Turns out the metal box that those plastic switches screw into was slightly dented around the area of the start plunger, which was contributing to it engaging on a slight angle. That combined with the slightly bent plastic plunger and I think it was barely hitting the start button inside and sliding off the side before fully engaging the switch. At least I hope that’s what was going on. No issues just starting it several times and planing some hard maple.

    I have a little bit of work to do on my grinding technique, though. The knives came to me with a fairly sizable nick right down the center of the blades and it looks like I didn’t quite grind it out 100%. I may need to grind them down a good bit more and reset them once they are fresh as it will be removing a decent amount of steel to get past the nick.

    I’m really enjoying the overall quality of this machine so far. It’s actually been fun diagnosing and solving all the minor little problems to get it up and running in optimal condition and feels like it’s a nice enough machine to be worth going the extra mile for.

    Thanks for the help!
    Last edited by Phillip Mitchell; 08-04-2020 at 6:26 PM.
    Still waters run deep.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts