Results 1 to 5 of 5

Thread: Ruida RDC 6442G-B Not reading UDisck or PC USB ports

  1. #1

    Ruida RDC 6442G-B Not reading UDisck or PC USB ports

    Hello,
    I think I have read all laser related posts for the past 6 or more years. GREAT forum AND Members!
    I have a brand new 80watt CO2 laser with Ruida RDC 6442G-B. I have been going through all the start-up steps, and all seems well untill I try to either hook a laptop to the laser USB port or insert a USB drive into the UDisk port.
    If I go through the laptop, I get "Communication Error". If I try to read the USB drive, I get "No files". The file name I used was test1.

    I Have RDWorks loaded on an older laptop Windows XP. I also borrowed the wife's laptop Windows 10, loaded Lightburn trial, same error. I ran a CAT6 100 foot cable from my primary desktop (Windows 10, where I have the first Lightburn trial downloaded to), same error. I back traced those USB ports on the laser, removed the cable from the actual RDC6442 controller, and plugged my laptop right in there (thinking maybe its a cable issue). Same error.

    When I turn the laser power switch on, it moves from a position in the middle of the laser bed up to far left corner, guess to "zero", then back to that middle bed position. I can use the X or Y jog buttons on the controller tough pad, they work, so I'm thinking the controller works (not blown). I "pulsed" the laser to align mirrors, two times (long story), that works fine.

    I have had the laser for (I'm embarrassed to say) since last May. I didn't have my "pole barn" built. I got tired of waiting for the new building and made a place in or garage to run it. I bought a 1/2" thick ground aluminum tool plate for the bed, got that leveled and mounted. I came up with a exhaust system (bring air in from outside and vent back to outside, I'll share pictures once I'm running). So I have been putzing with the laser, getting it set-up to what I think I want. And this forum is priceless, so much information, members are so helpful.

    And yes, I will update my profile to contain my laser, software, tools, etc. I have searched all the Lightburn forum Ruida topics and the internet, but can't find out what's going on. Day 3 or 4 on this issue, I lost track. I'm betting its something real simple..... any ideas?

    Many thanks!

  2. #2
    Here are my "Signatures" added to my posts .....
    Laser: Orion Motor Tech 80 watt Co2 Laser 500mm x 700mm work area (Black & Red cabinet)
    RUIDA RDC 6442G - B Controller (st'd on laser)
    EFR -F2 laser tube (st'd on machine)
    Lightburn software

  3. #3
    Well after pulling an all nighter, reading all the threads on Ruida on the Lightburn forum and also Ruida 6442 on private Facebook site, i have resolved this issue and fired the laser for the very first time. Works great. GREAT to see it actually work!

    Solution(s)
    1.) unloaded and reloaded RDWorks on Windows XP laptop.
    2.) Used (actually found in the bag supplied with the laser) the USB cable supplied with laser.

    Other "possible" causes could be....
    1.) "noise" on the USB port (so you buy an optical isolation device).
    2.) Laptop USB ports might be sleeping

    Well, it runs, makes smoke, burns. WHAT A GREAT SIGHT TO SEE!
    Laser: Orion Motor Tech 80 watt Co2 Laser 500mm x 700mm work area (Black & Red cabinet)
    RUIDA RDC 6442G - B Controller (st'd on laser)
    EFR -F2 laser tube (st'd on machine)
    Lightburn software

  4. #4
    Join Date
    Dec 2010
    Location
    NW Arkansas
    Posts
    1,689
    Blog Entries
    1
    I would work to set up a "network" rather than depend on USB. thae controllers are notorious as to the unreliability of usb communications. easy to make a network with a network switch. that way you can use ethernet connection direct into the controller faster than usb and totally reliable. I only get error if I forget to turn on machine.
    Woodworking, Old Tools and Shooting
    Ray Fine RF-1390 Laser
    Ray Fine 20watt Fiber Laser
    PM2000, Delta BS, Delta sander, Powermatic 50 jointer,
    Powermatic100-12 planer, Rockwell 15-126 radial drill press
    Rockwell 46-450 lathe, and 2 Walker Turner RA1100 radial saws

    RIA 22TCM 1911s

  5. #5
    Well done solving it.
    I use a network lead, and periodically have the controller or the PC saying they can't communicate, or are not connected-when they are.
    I make an RD file and transfer it by USB key in that case.
    There is no logic in the 'can't connect' messages.
    Best wishes,
    Ian



    ULS M-300, 55w made 2002 with rotary. Goldenlaser 130 watt, 1300x700 made 2011.
    Flat bed 2500x1300 150/90watt 2 tube laser, 2018 model.
    Esab router, 1989, 4.5 x 2.0 m, conv. to Tekcel, and modded a 2nd time.
    HP L260-60". Roland PNC-1410. Mimaki GC-130 SU.
    Screenprinting carousel 6x4 and 7x4 ft 1-arm bandit vac table.
    Corel Draw X3, Illy, Indesign & Photoshop CS2 & CS5, Enroute 4
    Pencil, paper, paintbrush, airbrush & dagger-liners & assorted other stuff.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •