Results 1 to 4 of 4

Thread: Accuris 14 30 watt problem need help

  1. #1
    Join Date
    Dec 2007
    Location
    Langley BC Canada
    Posts
    49

    Accuris 14 30 watt problem need help

    Hi,
    I have n Accuris 14 30 watt which is getting old now 2006 model. I started up the machine to do a small name tag job and the laser gave a large bang (like a balloon popping)

    Everything was still running and laser light on, I sent the job and the x y did not respond properly went to the centre of the table and on return to home banged into the home spot.

    I noticed that set positions on the control board would not work initially, I did the old turn off and on again and regained the working positions. I was able to complete a job without problems.

    My second job was using the rotary for a bottle again worked without issue. My problem is identifying the source of the bang sound and not really trusting the machine not to screw up.

    Has anyone had a similar problem or any ideas as to what could be going wrong. The Accuris has stepper motors.
    Accuris 14 30 W, Engravelab 7, CorelDraw X4, Photograv 3, Gravotech 3000 plotter

  2. #2
    The bang could've been a capacitor popping, and there's 2 of them in an RF laser tube. If one goes, the laser will still fire, but at half the power- try cutting something or deep engraving something to see if old power settings are still working.

    As to the xy and control panel not responding properly, that's almost exactly what my GCC Explorer did about a year after I got it. The screen when near 'white' and the head went near the middle and just quit. Then it worked once or twice, then did it again. Since nearly every electronics problem I've ever had always ended up being an iffy connection somewhere, I unplugged the machine, grabbed some needlenose pliers and a can of CRC electronics spray cleaner, then proceeded to pull every single plug off the motherboard (that I COULD pull off), sprayed the plug and pins and reconnected. I also loosened, sprayed and re-tightened every screw connection I could find. The only connections I didn't mess with were those at the tube itself. When I was done, it was like a brand new machine again, the screen's LCD readout was blacker than it ever was and it worked flawlessly. About a year later the screen started going light again, so I repeated the process. And just as a pre-emptive strike I did another cleaning just before the holidays.

    I highly recommend you try that, IF you're comfortable unplugging stuff
    ========================================
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle


  3. #3
    Join Date
    Dec 2007
    Location
    Langley BC Canada
    Posts
    49
    Kev, Thank you for the advice I will comply I tried reaching out to Sign Warehouse and they were very unhelpful just said we do not carry this anymore and switched me to a recording of their service plans.

    (not impressed) I will try your tips. Thank you.
    Accuris 14 30 W, Engravelab 7, CorelDraw X4, Photograv 3, Gravotech 3000 plotter

  4. #4
    You might try Jorlink.com for parts and info on these machines, I have a GCC Explorer and I got a complete schematic wiring diagrams from their website. (that was about 3 years ago, hopefully they're not getting too big for their britches these days)
    ========================================
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •