Results 1 to 5 of 5

Thread: MFC Application Stopped Working

  1. #1

    MFC Application Stopped Working

    Hi Folks. Its been a while since my last problem and I hate to have to be here asking. Has anyone ever had a problem opening EZCAD with a MFC application stopped working popup that prohibited the program from working. After having the scan head replaced I felt confident that this machine would be fine but here I am again with problems. I cant open the software and so my laser is non functioning once again. It is a Ray fine 30W MOPA with cyclops camera. I can open the software with the machine off and in demo mode so I suspect it has something to do with a hardware problem but hoping that I am missing something. All connections are good and up until today the laser was working flawlessly. Jim

  2. #2
    Join Date
    Mar 2014
    Iowa USA
    So you've created a MFC application for running EZCAD, If so why? What is your operating system?
    Retired Guy- Central Iowa. , LightObject 40w CO2 Laser and Chiller, MakerGear M2 3D Printer. Fine Line Automation 4x4 CNC Router- Mach4 ESS

  3. #3
    No i did not create a MFC application. I am not that computer savy to do that. I am using windows 10 but not connected to any wifi so there are no updates occuring on the system. The MFC errror shows up when I try to open EZCAD except when I do not have the laser on ( it will go into demo mode without the laser being on). I worked great until yesterday when I tried to start it up and I have not been able to open EZCAD since. Thanks

  4. #4
    Bill, "MFC Application" is EzCad, it's the 'program crashed' name for it-- Like when Gravostyle crashes I get 'Type3 has stopped working', and in the running applications it's "pltf". I'm not ever sure what MFC stands for, but it's just another name for EzCad

    My Triumph EzCad crashes quite often actually, and I believe both my ebay machines have crashed once. All my crashes are the result of something I'm doing the program doesn't like, usually when I have the screen filled up and I give it too many directions at once

    In James's case, if I read correctly, he's crashing on program boot but only when connected to the computer. First thing I'd try is a different USB port on the computer, then a different USB cable, then a different computer if possible. These tests will either find the problem or rule out external hardware, which would point to something within the laser. Control card may have a problem, or could be an iffy connection on the card or elsewhere in the machine. I'd suggest pulling and re-inserting connector plugs, and spray both ends with electronics cleaner spray.

    If all that doesn't stop the crash, then you likely have something needing replacing...
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle

  5. #5
    I was hoping that you would reply Kevin. Thank you! I tried swapping the cables and also different ports. The device manager reads all of the devices as working properly of course without the program running. I also tried a second computer and that came up with the same MFC Application error. I pulled the board and examined and found no obvious cracks or loose solder joints. I also used dielectric grease on all plugs and even remover the jumpers and greased them. No visible corrosion on any connections. I suspect something wrong with the board but don't know how I can check. I am hoping Rayfine will contact me back and have a simple way of checking to isolate a bad component without turning into a complete rebuild. I wonder if my original problem with the scan head was a cause or if the board caused a problem with the scan head originally. I am about to the point of just selling this thing as parts and finding another business. Thanks Jim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts