Results 1 to 4 of 4

Thread: Epilog laser wonít go home, looking for miracle solution

  1. #1

    Epilog laser wonít go home, looking for miracle solution

    Hiya laser community

    We have a 50W Epilog Zing CO2 laser. The Y-Axis keeps homing at about the 6.5" mark out on the ruler guide as if the rotary attachment were connected, even though its not. The Zing automatically knows the rotary is attached once you connect it via its controller cable. Up until this homing problem began, it did work flawlessly, self-adjusting the home position for the rotary, then returning to the rear, left when the rotary was disconnected (always connected and disconnected with machine off).

    Epilog Support suggested the motor wasn't pulling properly, but the rail and carriage seem to have no issues moving, they just end up in the wrong place. I replaced the motor anyway, no improvement (but now I have a back up motor). Here is what I've tried so far ...

    • I made sure the sensor is clean and belts are tight.
    • I tried turning off X/Y and moving the rail back to the normal home position
    • I manually set the home to factory default positions (X -152, Y +200) using the Config Menu in the machine's LCD display
      Note: There is no Restore option in the LCD Config Menu on the machine or in the Epilog driver interface on a computer.
    • I tried reconnecting and disconnecting the rotary to see if that would reset it.

    But as soon as I power off and on, or punch the Reset or Go button, the rail returns to the home position for the rotary attachment.

    As far as I can tell, the machine is working properly in all regards to hardware, but is confused about where home is, which seems like a software glitch to me.

    A new control board from Epilog cost over $1K+ so I just wanted to see if anyone knew of a fix, or trick even.

    Any suggestions are welcome, thanks!

  2. #2
    I have 3 machines with rotary's, 2 Gravographs and my GCC Explorer (aka Pinnacle)- common to all 3 of these machines is that upon boot up, the gantry must first go 'home' to trip the limit switches to find the top/left 0/0 position, BEFORE it will go to the rotary's 0/0 position. Since the rotary's have no limit switches, it's necessary to find the 'base' 0/0 before the machine knows where the rotary's 0/0 is.

    Of note, my Gravograph's use stepper motors, the GCC uses servo's, and the GCC's rotary does have a specific zero position, which is handy at times, the Gravo rotary's have no set zero position. Regardless, the rotary still needs to know where the machine's base zero point is before it can know where the rotary zero is, because the gantry's X and Y positions move.

    So, does/did your machine home the corner before moving to rotary zero prior to this issue? Does it still do that?
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle

  3. #3
    Join Date
    Mar 2014
    Iowa USA
    So whatever tells the machine the rotary is attached is what? Switch, sensor or otherwise. Surprised that Factory could not help you out.
    Retired Guy- Central Iowa. , LightObject 40w CO2 Laser and Chiller, MakerGear M2 3D Printer. Fine Line Automation 4x4 CNC Router- Mach4 ESS

  4. #4
    Join Date
    Sep 2009
    Medina Ohio
    On my Chinese laser if I move the starting point to a new location and start then shut down the next time it will home to that location

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts