Results 1 to 2 of 2

Thread: Installing Gravostyle 5 or 98 on Windows 10 x64 TUT

  1. #1

    Installing Gravostyle 5 or 98 on Windows 10 x64 TUT

    I made this video for my self so i can watch it back and install Gravostyle 5 the right way on Windows 10 x64.
    But i thought why not share it Make sure to follow the steps i take very carefully.
    On the end of the video the job was succesfully send to our IS800 and received.

    This method should be working with Gravostyle 98 too.
    But i can't show that because, our company doesn't have a license for that.

    Drivers from Gravostyle 8.5 are needed instead of the drivers from 5 because,
    only the newest work in Windows 10 x64 but, they work fine with Gravostyle 5.

    I made a zip from the Drivers so you don't have to download Gravostyle 8.5 only for the drivers.

    Make sure you make a shortcut in :
    (C:\Users\YOURNAME\AppData\Roaming\Microsoft\Window s\Printer Shortcuts)
    With the exact same name as your printer.
    In my case (GT Smartstream) otherwise you won't be able to add your printer/machine.

    Here is a PDF version of the video:

    GravoGraph support downloads:
    Last edited by Chris Andriessen; 05-19-2019 at 8:14 AM.

  2. #2
    Fair warning on using newer drivers on older machines, as I fubared something (no one's sure of what exactly) in the controller of my 2004 LS900 laser several years ago... It happily runs Gravo 98, 5 and 5.3 and all drivers 4.06-3 and older...then I got 7-Discovery with the IS-400 P&S I bought, which has the 5.21-3 L-solution driver, but, the machine wouldn't upload the firmware. What the hell, I ran it anyway, what could go wrong? All was okay until I tried rastering using the engrave-UP and 3200 dpi settings- the machine went bonkers, the laser head about took out the right wall of the machine at 900 mph, then headed south at about 1 speed with the laser firing full on... And ever since that day, if I try to vector ANYthing using Gravostyle, the driver goes TU and the gantry just creepy crawls to the right at 0 speed, sometimes laser on, sometimes off. Just keeps going until I turn the machine off. The funny thing is, the driver works just fine in Corel, right up until I try vectoring in Gravo- then it won't vector in Corel either. The fix is to power down the machine, delete then reload the driver. Then all is well in Corel. Rastering is fine in Gravo, BUT, if there's any open vectors within the job area, even if not engraved, the driver will tank. It's a $1200 fix, which will also upgrade the controller to accept USB input (mine is LPT or serial input only) which would be okay, but I've just lived with it since 99% of engraving I can do using Corel.

    The new-to-me LS100 I got a few months ago has the 7.04-3 driver, the LS900 won't load it's firmware either. Wish it would, because since it won't I have to have a separate computer to run the LS100, since you can't load 2 different Gravo laser drivers on the same computer. But it ain't worth $1200 to me

    As for using Windows 10, not me.. with the exception of my 2 newest fiber lasers, it's incompatible with virtually every other machine, every piece of office equipment and all the software I use to run it all.
    ELEVEN - rotary cutter tool machines
    FOUR - CO2 lasers
    THREE - fiber lasers
    ONE - vinyl cutter
    CASmate, Corel, Gravostyle

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts