Results 1 to 6 of 6

Thread: Use Ridgid OSS not oscillating. Has anyone ever taken theirs apart?

  1. #1

    Question Use Ridgid OSS not oscillating. Has anyone ever taken theirs apart?

    I bought a used Ridgid OSS. It was originally listed for $100 which seems like the going rate. But when I got there I found it wasn't oscillating. So I offered $50 and she took it. She was cleaning out her dads shop. There wasn't much left but she offered a couple small work tables to go with it and for another $10 I got quite a bit of oak and maple boards. So even if the sander can't be fixed it wasn't a bad deal.

    The sander will oscillate one time and stop at the top and start vibrating. I took the oscillating assembly apart and found that there is a bronze gear that engages a larger plastic gear. Those two come apart and I believe that is the problem. When I re-seat them, put it back together and test, it again oscillates one time and then vibrates. Again disassemble and those two parts are separated again.

    From what I can find online no one has taken that oscillating assembly apart and posted anything. The manual shows it as part of the motor/drive assembly so I am getting into uncharted waters. But I thought I would try here to see if anyone has had any luck with a similar problem.

    I put together a video (which confirmed I will never be a Youtube star) where I show it broken down. Since I surely could not get the parts I need without buying the whole assembly, my thought is to just epoxy the parts together. From what it looks like they are supposed to be engaged at all times but they probably used two parts - one metal and on plastic - to save on cost.

    Any thoughts would be appreciated.

    https://youtu.be/tQEzl80oSGU

  2. #2
    Can you put a split collar on the shaft to hold the gear in place?

    I have taken Grizzlys apart.

  3. #3
    That is a good idea. I think it might work and would be removable if it didn't. I'll give it a try and report back.

  4. #4
    Join Date
    Mar 2003
    Location
    Upland CA
    Posts
    4,049
    I think Kevin is on the right track. Bet it is missing an E-clip, or some other 'keeper' that keeps things in the right place.

    Wonder why the original owner didn't get it replaced/fixed. It looks hardly used.
    Rick Potter

    DIY journeyman,
    FWW wannabe.
    AKA Village Idiot.

  5. #5
    Join Date
    Sep 2007
    Location
    Upstate NY
    Posts
    3,273
    YMMV
    I had a Rigid OSS/belt sander that stopped working. The local repair depot fixed it for free with no proof of anything. Worth asking.

  6. #6
    IT IS FIXED! but not with the split ring or any epoxy. I found that dang thing was assembled incorrectly. Since the manual doesn't show you that inner workings of the drive assembly I made the incorrect assumption about how it was supposed to be put back together. I am not sure if it was wrong when I got it or if I put it back together wrong. Since the problem persisted after I reassembled I tend to think it was wrong when I got it.

    Of the two plastic plates at the bottom of the shaft the lower one has several posts on the top that are supposed to mate with holes on the upper plate. You can see the holes at 3:46 in the video. The holes are larger in diameter than the posts so at first it didn't really seem like they were supposed to match up. And when I first took it apart and reassembled it didn't seem to want to go together with posts in the holes. So I assumed that was incorrect. It was not.

    This last time while trying to install the split ring it just happened to slide together correctly. When I saw this it clicked pretty quickly. Similar to my diagnosis I posted here I had at one point thought that the upper plate, with the gear teeth, was rising above the mating teeth in the housing. I think that is what was happening. When the plates are assembled wrong the upper plate rides a bit higher. So I think when it oscillated to the top of the motion the gear plate was disengaging the teeth in the housing just enough to stop oscillating and cause the vibration. The plate coming off that bronze inner gear was just a symptom and not the cause.

    This is all still a bit of conjecture since you can't see inside the housing while it is running to confirm all this but I can say that it is working now. I haven't run it for a long time yet but I have tested for several minutes and did some sanding and so far it is working.

    I then had to clean the opening in side the belt adapter because it wasn't sliding onto the upper shaft. A little sandpaper around a screwdriver and that cleaned out the corrosion inside that belt drive wheel. Then a bit of T9 around the upper shaft bearing to eliminate a squeak and we are in business.

    Thanks for the advice anyway folks. I definitely wanted to follow up here in case someone else comes across this thread with the same issue.
    Last edited by Tony Vrolyk; 12-08-2018 at 7:03 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •