Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

Thread: Issue with 20Watt Fibre laser engraver from Ebay ( China )

  1. #16
    Who cares if it's sealed, can't void a warranty that doesn't seem to exist! pull the cover and check all the connections.


  2. #17
    Join Date
    Dec 2010
    Location
    NW Arkansas
    Posts
    1,433
    Yep, Check top (behind the head) cables also, I had one come a loose when I moved the laser.

    I'd change all my cables also. I have a cheeep 3D printer. Came with a 24" USB cable to connect to PC. Didn't work. Tried 3 other cables before I found one that actually worked. Some machines are really particular.
    Woodworking, Old Tools and Shooting
    Ray Fine RF-1390 Laser
    Ray Fine 20watt Fiber Laser
    PM2000, Delta BS, Delta sander, Powermatic 50 jointer,
    Powermatic100-12 planer, Rockwell 15-126 radial drill press
    Rockwell 46-450 lathe, and 2 Walker Turner RA1100 radial saws

    RIA 22TCM 1911s

  3. #18
    SOLVED - I went threw the process of elimination and determined that the issue resides in the Y-Axis Galvo, The motor seems to fault out after about 2-3 minutes of run time. Trying to find a replacement now

  4. #19
    if there's any way possible to borrow a scanhead before buying one, definitely try that- best scenario is to get the seller involved since it's a warranty issue (I'm assuming)

    I've found over the years that something like that mirror not moving may not be the mirror-- since each mirror is controlled by its own wired connection, could be the wire or connection or the data flowing thru it isn't right. You're likely right, but Murphy's law is always in full effect... at least around MY place

    Other scenario would be to have your scanhead checked locally first, all it takes is another fiber laser to plug it in to. If it's bad, it'll be bad when tested elsewhere...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •