Page 1 of 2 12 LastLast
Results 1 to 15 of 18

Thread: Bosch 1587vs

  1. #1
    Join Date
    May 2006
    Location
    Stevens Point
    Posts
    99

    Bosch 1587vs

    Need advice on 1587vs locking knob. When I pull up on the locking knob to loosen the blade the black knob pops out of the handle. Started doing this a year ago. Made do with the problem but would like to figure why it is doing now. Learned to be gentle while pulling it up and rotating it but occassionly still pops out. Any ideas or has anyone experienced this problem?

  2. #2
    I can't answer your question myself. But, in the past when I had questions about a Bosch tool and called them, I did get to talk to a knowledgeable technician.

  3. #3
    Join Date
    Mar 2006
    Location
    SoCal
    Posts
    21,229
    Blog Entries
    1
    Quote Originally Posted by Paul Stroik View Post
    Learned to be gentle while pulling it up and rotating it but occassionly still pops out.
    Every one I have used (not mine) does that. Even though I am expecting it and try to use a bit of finesse, it will still happen to me. I have the 1591 which uses a different system. I would like to hear what Bosch says about it though. There could be a simple, common mistake in operation that we are both doing(?).
    I always forget . . . Is it the letter "S" or the letter "C" that is silent in the word scent?
    - Glenn (the second "N" is silent) Bradley

  4. #4
    Join Date
    May 2006
    Location
    Stevens Point
    Posts
    99
    I will call Bosch on Monday for a solution. Hate to get rid of it but would like nothing more than to have a reason to pickup the 1591.

    thanks all

  5. #5
    Quote Originally Posted by Paul Stroik View Post
    ... would like nothing more than a 1591.

    thanks all
    That's a good enough reason to get one.



    Forgive my editing.

  6. #6
    Join Date
    Jun 2007
    Location
    SCal
    Posts
    1,427
    Did anyone ever get an answer from Bosch?

  7. #7
    Join Date
    May 2006
    Location
    Stevens Point
    Posts
    99
    I called Bosch. They haven't heard of this problem before. According to them I need to send the jigsaw in for service so they are sending me a service slip. Means I will have to send it in if I want it repaired.
    So far I haven't found anything on the internet relating to this type of problem. It still works as long as I am gentle in pulling up on the locking knob. It's a minor issue I guess. Everything else works great otherwise.
    The new style blade locking mechanism on the newer style Jigsaws seems to be the cats meow.

  8. #8
    Join Date
    Jun 2007
    Location
    SCal
    Posts
    1,427
    Paul,, strange how when you call tech support, we are the always the only time they ever heard of this problem. I have been dealing with mine the same way you have.... takes 5 tries...

    which model has this new design you refer to?

  9. #9
    Join Date
    May 2006
    Location
    Stevens Point
    Posts
    99
    I think all the newer models have the new blade changing quick release, which is located up front. A flip of the lever ejects the blade and ready for a new blade.
    1590, 1591, and JS470EB are a couple of them. I was looking at the 1591vs but will hold off since mine is still working well.

  10. #10
    Join Date
    Mar 2006
    Location
    Northeast Ohio
    Posts
    504
    The knob on mine pulled out within the first month I had it. I never had it serviced as I use the saw infrequently. I just try to be careful when I install or remove a blade. It is annoying when it happens though.

    I like the saw very much though and would buy another. Just one of life's little inconveniences.

  11. #11
    Join Date
    May 2006
    Location
    Stevens Point
    Posts
    99

    New parts

    I decided to replace the Top Handle Assembly. Ordered the parts from ereplacements rather than sending the entire tool in for repair. Switched out the top handle assembly myself and it now works like new. It took about 5 minutes to replace. Very inexpensive fix.

  12. #12
    Join Date
    Jun 2007
    Location
    SCal
    Posts
    1,427
    Paul, do you have the email that was sent to you from them, with the part numbers, I will duplicate your efforts... thx for sharing...

  13. #13
    Join Date
    May 2006
    Location
    Stevens Point
    Posts
    99
    If you are referring to email from the Bosch service dept. I spoke with them over the phone - no email. They were going to send me a service slip (7-10 days) so that I could send my jigsaw in for repairs. I decided to give Ereplacment a try. So I ordered the part from Ereplacement taking the chance that this would be the right fix. Glad I did.

    The Ereplacement part I ordered from the parts list on their site is item number 826 - parts #2602025901 labeled as Top Handle Assembly.

  14. #14
    Join Date
    Jun 2007
    Location
    SCal
    Posts
    1,427
    Done, thx again for sharing...

    I thought the post would need replacing as well, as it looks beat up, but since you had success with just the top part, I will give it a go...

  15. #15
    Join Date
    May 2010
    Location
    Lewisville, NC
    Posts
    267
    Blog Entries
    2
    Quote Originally Posted by Paul Stroik View Post
    I decided to replace the Top Handle Assembly. Ordered the parts from ereplacements rather than sending the entire tool in for repair. Switched out the top handle assembly myself and it now works like new. It took about 5 minutes to replace. Very inexpensive fix.
    Paul, I had this problem first time I changed blades. Please send me a PM on part #, etc so I can finally fix this problem. Thanks
    David Woodruff

    If you don't know where you're going, it doesn't matter how you get there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •