PDA

View Full Version : My Lasers Down



Matty McQuilkin
12-07-2010, 2:51 PM
Today we had a power surge and my Mercury is now not putting out power.
I think that I might have blown out the RF Boards on the laser.
Some time ago I saw on this site where someone repaired there RF boards themselves.
I have searched for that article canít find it. Anyone know the link or any suggestions

Thanks Matty

Viktor Voroncov
12-07-2010, 3:35 PM
Did you check fuses first?
What is your tube? Year of manufacturing?

Matty McQuilkin
12-07-2010, 6:30 PM
Viktor thanks for the reply


Well Iím not sure why , but the laser is running again.
All I did was open up the back panel where the laser is and presto working again.?


Matty

Richard Rumancik
12-07-2010, 8:45 PM
I'll bet you are going to run out and buy a good quality surge suppressor as soon as possible. . . .right? You can get a decent 3000 joule suppressor for less than $25. (That's if you are running at 120VAC not 240.) If you have more money to spend there are more expensive options but you need to have at least a basic suppressor.

Viktor Voroncov
12-08-2010, 2:58 AM
Agree with Richard! Surge suppressor is more important for laser than UPS.

You are lucky, Matty!:D

Richard Rumancik
12-08-2010, 12:36 PM
Matty, I hope you never have to fiddle with the RF boards. Just for completeness, here is one thread which has some info:

http://www.sawmillcreek.org/showthread.php?t=65590&highlight=laser

It was Darren Null who did this. I know Rodne has done it as well.

You can search on "Synrad RF" to find any info.

If it has a Deos tube you won't find much repair info on this forum.

Matty McQuilkin
12-14-2010, 1:07 AM
I bought a surge suppressor so that should help.
The laser is still going ok, just hope it stays that way.
Thanks again Matty